Skip to content

VM Migration Failed. CloudStack 4.22.1.0+XCP-NG 8.2.1 #13721

Description

@sptest232

problem

Please help me figure out the reason for the virtual machine migration error.

The VM is started and it's connected to L2 network. When I try to migrate the VM to the another host of the pool I get an error "Unable to support this type of network broadcast domain: null". The same situation with some other VMs wich are connected to a VPC network.
At the same time, some other VMs of the same pool connected to other L2 networks migrate without problems.

VM configuration:
{
"count": 1,
"virtualmachine": [
{
"account": "test",
"affinitygroup": [],
"arch": "x86_64",
"cpunumber": 8,
"cpuspeed": 1000,
"cpuused": "0.43%",
"created": "2026-07-16T10:41:24+0300",
"deleteprotection": false,
"details": {
"Message.ReservedCapacityFreed.Flag": "false",
"cpuNumber": "8",
"cpuOvercommitRatio": "4",
"hypervisortoolsversion": "xenserver56",
"memory": "12288",
"memoryOvercommitRatio": "2",
"platform": "device-model:qemu-upstream-compat;apic:true;viridian:true;timeoffset:0;cores-per-socket:1;pae:true;acpi:1;hpet:true;secureboot:false;nx:true",
"rootdisksize": "40"
},
"diskioread": 0,
"diskiowrite": 0,
"diskkbsread": 66,
"diskkbswrite": 485,
"diskofferingid": "57bf8694-722b-4b72-939d-f8367aeb95a3",
"diskofferingname": "test",
"displayname": "test-vm",
"displayvm": true,
"domain": "test",
"domainid": "9cfeffa6-7064-4f6d-9e87-71da84db99b0",
"domainpath": "ROOT/test",
"guestosid": "3610579a-4224-11ec-8697-62c4e64309fe",
"haenable": true,
"hasannotations": false,
"hostcontrolstate": "Enabled",
"hostid": "c7722e69-1320-44f7-8dd9-da7f64a50fa2",
"hostname": "xcp-test",
"hypervisor": "XenServer",
"id": "943abbd3-0fe1-4a8d-9103-b720df48c31b",
"instancename": "i-222-2222-VM",
"isdynamicallyscalable": false,
"lastupdated": "2026-07-22T11:25:37+0300",
"memory": 12288,
"memoryintfreekbs": 6191235,
"memorykbs": 12582912,
"memorytargetkbs": 0,
"name": "test",
"networkkbsread": 24,
"networkkbswrite": 0,
"nic": [
{
"deviceid": "0",
"extradhcpoption": [],
"id": "413f962f-8c50-4960-be13-06f386740d39",
"isdefault": true,
"macaddress": "02:07:07:72:00:15",
"networkid": "f004cc1c-dbc7-46e2-b68f-f94486f79580",
"networkname": "test-net",
"secondaryip": [],
"traffictype": "Guest",
"type": "L2"
}
],
"osdisplayname": "Other Linux (64-bit)",
"ostypeid": "3610579a-4224-11ec-8697-62c4e64309fe",
"passwordenabled": false,
"pooltype": "PreSetup",
"receivedbytes": 0,
"rootdeviceid": 0,
"rootdevicetype": "ROOT",
"securitygroup": [],
"sentbytes": 0,
"serviceofferingid": "d7b6331a-6647-4194-9700-bac19cc6989e",
"serviceofferingname": "test",
"state": "Running",
"tags": [],
"templatedisplaytext": "test",
"templateformat": "ISO",
"templateid": "86f7dd7b-300e-45bd-8309-c79598dc6cfd",
"templatename": "Test",
"templatetype": "USER",
"userid": "7aac7740-5899-4af0-a1eb-f2fd1e1d8dc3",
"username": "test",
"zoneid": "9505445a-7164-4675-876d-1a2fee1f7e46",
"zonename": "test-zone"
}
]
}

Network configuration:

{
"count": 1,
"network": [
{
"account": "test",
"acltype": "Account",
"broadcastdomaintype": "Vlan",
"broadcasturi": "vlan://1234",
"canusefordeploy": true,
"created": "2026-05-14T14:22:10+0300",
"details": {
"hideIpAddressUsage": "false"
},
"displaynetwork": true,
"displaytext": "test-net",
"dns1": "1.1.1.1",
"dns2": "8.8.8.8",
"domain": "test",
"domainid": "9cfeffa6-7064-4f6d-9e87-71da84db99b0",
"domainpath": "ROOT/test",
"hasannotations": false,
"id": "f004cc1c-dbc7-46e2-b68f-f94486f79580",
"ispersistent": false,
"issystem": false,
"name": "test-net",
"networkofferingavailability": "Optional",
"networkofferingconservemode": true,
"networkofferingdisplaytext": "test-net L2",
"networkofferingid": "55634a31-3d5f-45ad-84dc-093ff55db8b9",
"networkofferingname": "test-net L2",
"physicalnetworkid": "636227a2-081e-4494-bd93-6adeea0e768a",
"privatemtu": 1500,
"publicmtu": 1500,
"receivedbytes": 0,
"redundantrouter": false,
"related": "f004cc1c-dbc7-46e2-b68f-f94486f79580",
"restartrequired": false,
"sentbytes": 0,
"service": [],
"specifyipranges": false,
"specifyvlan": true,
"state": "Setup",
"strechedl2subnet": false,
"supportsvmautoscaling": false,
"tags": [],
"traffictype": "Guest",
"type": "L2",
"vlan": "1234",
"zoneid": "9505445a-7164-4675-876d-1a2fee1f7e46",
"zonename": "test-zone"
}
]
}

Here is the ACS's log:

2026-07-24 12:39:25,033 DEBUG [c.c.a.t.Request] (Work-Job-Executor-133:[ctx-71b90daf, job-155111/job-155112, ctx-dbc25316]) (logid:cf26e16a) Seq 77361-801359258695256835: Executing: { Cmd , MgmtId: 108597816265214, via: 77361(xcp-test), Ver: v1, Flags: 100111, [{"com.cloud.agent.api.PrepareForMigrationCommand":{"vm":{"id":"9679","name":"i-222-2222-VM","bootloader":"PyGrub","state":"Running","type":"User","cpus":"8","minSpeed":"700","maxSpeed":"1000","minRam":"(6.00 GB) 6442450944","maxRam":"(12.00 GB) 12884901888","arch":"x86_64","os":"Other Linux (64-bit)","platformEmulator":"Other install media","bootArgs":"","enableHA":"true","limitCpuUse":"false","enableDynamicallyScaleVm":"false","details":{"cpuNumber":"8","memory":"12288","memoryOvercommitRatio":"2","Message.ReservedCapacityFreed.Flag":"false","hypervisortoolsversion":"xenserver56","cpuOvercommitRatio":"4","rootdisksize":"40","platform":"device-model:qemu-upstream-compat;apic:true;viridian:true;timeoffset:0;cores-per-socket:1;pae:true;acpi:1;hpet:true;secureboot:false;nx:true"},"uuid":"943abbd3-0fe1-4a8d-9103-b720df48c31b","enterHardwareSetup":"false","disks":[{"data":{"org.apache.cloudstack.storage.to.VolumeObjectTO":{"uuid":"7db3b617-de76-47c4-806f-4f480dec55af","volumeType":"ROOT","dataStore":{"org.apache.cloudstack.storage.to.PrimaryDataStoreTO":{"uuid":"test","name":"test","id":"84","poolType":"PreSetup","host":"localhost","path":"/test","port":"0","url":"PreSetup://localhost/test/?ROLE=Primary&STOREUUID=test","isManaged":"false"}},"name":"ROOT-2222","size":"(40.00 GB) 42949672960","path":"22472c93-e335-4136-ad67-d7bc5eb18434","volumeId":"11120","vmName":"i-222-2222-VM","accountId":"222","format":"VHD","provisioningType":"THIN","poolId":"84","id":"11120","deviceId":"0","bytesReadRate":"(0 bytes) 0","bytesWriteRate":"(0 bytes) 0","iopsReadRate":"(0 bytes) 0","iopsWriteRate":"(0 bytes) 0","cacheMode":"NONE","hypervisorType":"XenServer","directDownload":"false","deployAsIs":"false","checkpointPaths":[],"checkpointImageStoreUrls":[],"followRedirects":"true"}},"diskSeq":"0","path":"22472c93-e335-4136-ad67-d7bc5eb18434","type":"ROOT","details":{"storageHost":"localhost","managed":"false","storagePort":"0","protocoltype":"PreSetup","storage.pool.disk.wait":"60","volumeSize":"(40.00 GB) 42949672960"}},{"data":{"org.apache.cloudstack.storage.to.TemplateObjectTO":{"id":"0","format":"ISO","accountId":"0","hvm":"false","bootable":"false","directDownload":"false","deployAsIs":"false","followRedirects":"false"}},"diskSeq":"3","type":"ISO"}],"nics":[{"deviceId":"0","networkRateMbps":"10000","defaultNic":"true","pxeDisable":"false","nicUuid":"413f962f-8c50-4960-be13-06f386740d39","details":{"PromiscuousMode":"false","ForgedTransmits":"true","MacLearning":"false","MacAddressChanges":"true"},"dpdkEnabled":"false","networkId":"1906","networkSegmentName":"D124-A229-Z7-S1906","uuid":"f004cc1c-dbc7-46e2-b68f-f94486f79580","mac":"02:07:07:72:00:15","dns1":"1.1.1.1","dns2":"8.8.8.8","broadcastType":"Vlan","type":"Guest","securityGroupEnabled":"false","name":"test"}],"vcpuMaxLimit":"32","configDriveLabel":"config-2","configDriveLocation":"SECONDARY","guestOsDetails":{},"extraConfig":{},"networkIdToNetworkNameMap":{"1906":"D124-A229-Z7-S1906"}},"rollback":"false","wait":"0","bypassHostMaintenance":"false"}}] }

2026-07-24 12:39:25,043 WARN [c.c.h.x.r.w.x.CitrixPrepareForMigrationCommandWrapper] (DirectAgent-188:[ctx-df8d7551]) (logid:cf26e16a) Catch Exception com.cloud.utils.exception.CloudRuntimeException prepare for migration failed due to com.cloud.utils.exception.CloudRuntimeException: Unable to support this type of network broadcast domain: null com.cloud.utils.exception.CloudRuntimeException: Unable to support this type of network broadcast domain: null
at com.cloud.hypervisor.xenserver.resource.CitrixResourceBase.getNetwork(CitrixResourceBase.java:2894)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixPrepareForMigrationCommandWrapper.execute(CitrixPrepareForMigrationCommandWrapper.java:60)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixPrepareForMigrationCommandWrapper.execute(CitrixPrepareForMigrationCommandWrapper.java:35)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixRequestWrapper.execute(CitrixRequestWrapper.java:122)
at com.cloud.hypervisor.xenserver.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:1779)
at com.cloud.agent.manager.DirectAgentAttache$Task.runInContext(DirectAgentAttache.java:306)
at org.apache.cloudstack.managed.context.ManagedContextRunnable$1.run(ManagedContextRunnable.java:49)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext$1.call(DefaultManagedContext.java:56)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext.callWithContext(DefaultManagedContext.java:103)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext.runWithContext(DefaultManagedContext.java:53)
at org.apache.cloudstack.managed.context.ManagedContextRunnable.run(ManagedContextRunnable.java:46)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:539)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
at java.base/java.lang.Thread.run(Thread.java:840)

2026-07-24 12:39:25,043 DEBUG [c.c.a.m.D.Task] (DirectAgent-188:[ctx-df8d7551]) (logid:cf26e16a) Seq 77354-801359258695256835: Response Received:
2026-07-24 12:39:25,044 DEBUG [c.c.a.t.Request] (DirectAgent-188:[ctx-df8d7551]) (logid:cf26e16a) Seq 77361-801359258695256835: Processing: { Ans: , MgmtId: 108597816265214, via: 77361(xcp-test
l), Ver: v1, Flags: 110, [{"com.cloud.agent.api.PrepareForMigrationAnswer":{"dpdkInterfaceMapping":{},"result":"false","details":"Exception: com.cloud.utils.exception.CloudRuntimeException
Message: Unable to support this type of network broadcast domain: null
Stack: com.cloud.utils.exception.CloudRuntimeException: Unable to support this type of network broadcast domain: null
at com.cloud.hypervisor.xenserver.resource.CitrixResourceBase.getNetwork(CitrixResourceBase.java:2894)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixPrepareForMigrationCommandWrapper.execute(CitrixPrepareForMigrationCommandWrapper.java:60)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixPrepareForMigrationCommandWrapper.execute(CitrixPrepareForMigrationCommandWrapper.java:35)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixRequestWrapper.execute(CitrixRequestWrapper.java:122)
at com.cloud.hypervisor.xenserver.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:1779)
at com.cloud.agent.manager.DirectAgentAttache$Task.runInContext(DirectAgentAttache.java:306)
at org.apache.cloudstack.managed.context.ManagedContextRunnable$1.run(ManagedContextRunnable.java:49)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext$1.call(DefaultManagedContext.java:56)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext.callWithContext(DefaultManagedContext.java:103)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext.runWithContext(DefaultManagedContext.java:53)
at org.apache.cloudstack.managed.context.ManagedContextRunnable.run(ManagedContextRunnable.java:46)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:539)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
at java.base/java.lang.Thread.run(Thread.java:840)
","wait":"0","bypassHostMaintenance":"false"}}] }
2026-07-24 12:39:25,044 DEBUG [c.c.a.m.ClusteredDirectAgentAttache] (DirectAgent-188:[ctx-df8d7551]) (logid:cf26e16a) Seq 77354-801359258695256835: No more commands found
2026-07-24 12:39:25,044 DEBUG [c.c.a.t.Request] (Work-Job-Executor-133:[ctx-71b90daf, job-155111/job-155112, ctx-dbc25316]) (logid:cf26e16a) Seq 77361-801359258695256835: Received: { Ans: , MgmtId: 1085978162652
14, via: 77361(xcp-test), Ver: v1, Flags: 110, { PrepareForMigrationAnswer } }
2026-07-24 12:39:25,044 ERROR [c.c.v.ClusteredVirtualMachineManagerImpl] (Work-Job-Executor-133:[ctx-71b90daf, job-155111/job-155112, ctx-dbc25316]) (logid:cf26e16a) Failed to prepare destination host 77361 for m
igration of VM i-222-2222-VM : Exception: com.cloud.utils.exception.CloudRuntimeException
Message: Unable to support this type of network broadcast domain: null
Stack: com.cloud.utils.exception.CloudRuntimeException: Unable to support this type of network broadcast domain: null
at com.cloud.hypervisor.xenserver.resource.CitrixResourceBase.getNetwork(CitrixResourceBase.java:2894)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixPrepareForMigrationCommandWrapper.execute(CitrixPrepareForMigrationCommandWrapper.java:60)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixPrepareForMigrationCommandWrapper.execute(CitrixPrepareForMigrationCommandWrapper.java:35)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixRequestWrapper.execute(CitrixRequestWrapper.java:122)
at com.cloud.hypervisor.xenserver.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:1779)
at com.cloud.agent.manager.DirectAgentAttache$Task.runInContext(DirectAgentAttache.java:306)
at org.apache.cloudstack.managed.context.ManagedContextRunnable$1.run(ManagedContextRunnable.java:49)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext$1.call(DefaultManagedContext.java:56)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext.callWithContext(DefaultManagedContext.java:103)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext.runWithContext(DefaultManagedContext.java:53)
at org.apache.cloudstack.managed.context.ManagedContextRunnable.run(ManagedContextRunnable.java:46)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:539)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
at java.base/java.lang.Thread.run(Thread.java:840)

2026-07-24 12:39:25,045 DEBUG [c.c.v.UserVmManagerImpl] (Work-Job-Executor-133:[ctx-71b90daf, job-155111/job-155112, ctx-dbc25316]) (logid:cf26e16a) Skipping PVLAN setup on host 77353 for NIC NicProfile {"broadca
stUri":null,"deviceId":0,"iPv4Address":null,"id":14523,"reservationId":"a0591da5-b287-4749-a8fb-4aab81035be3","uuid":"413f962f-8c50-4960-be13-06f386740d39","vmId":9679} because broadcast URI is null

2026-07-24 12:39:25,056 ERROR [c.c.v.VmWorkJobHandlerProxy] (Work-Job-Executor-133:[ctx-71b90daf, job-155111/job-155112, ctx-dbc25316]) (logid:cf26e16a) Invocation exception, caused by: com.cloud.exception.AgentU
navailableException: Resource [Host:77361] is unreachable: Host 77361: Unable to prepare for migration due to Exception: com.cloud.utils.exception.CloudRuntimeException
Message: Unable to support this type of network broadcast domain: null
Stack: com.cloud.utils.exception.CloudRuntimeException: Unable to support this type of network broadcast domain: null
at com.cloud.hypervisor.xenserver.resource.CitrixResourceBase.getNetwork(CitrixResourceBase.java:2894)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixPrepareForMigrationCommandWrapper.execute(CitrixPrepareForMigrationCommandWrapper.java:60)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixPrepareForMigrationCommandWrapper.execute(CitrixPrepareForMigrationCommandWrapper.java:35)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixRequestWrapper.execute(CitrixRequestWrapper.java:122)
at com.cloud.hypervisor.xenserver.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:1779)
at com.cloud.agent.manager.DirectAgentAttache$Task.runInContext(DirectAgentAttache.java:306)
at org.apache.cloudstack.managed.context.ManagedContextRunnable$1.run(ManagedContextRunnable.java:49)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext$1.call(DefaultManagedContext.java:56)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext.callWithContext(DefaultManagedContext.java:103)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext.runWithContext(DefaultManagedContext.java:53)
at org.apache.cloudstack.managed.context.ManagedContextRunnable.run(ManagedContextRunnable.java:46)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:539)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
at java.base/java.lang.Thread.run(Thread.java:840)

2026-07-24 12:39:25,056 INFO [c.c.v.VmWorkJobHandlerProxy] (Work-Job-Executor-133:[ctx-71b90daf, job-155111/job-155112, ctx-dbc25316]) (logid:cf26e16a) Rethrow exception com.cloud.exception.AgentUnavailableExcep
tion: Resource [Host:77361] is unreachable: Host 77361: Unable to prepare for migration due to Exception: com.cloud.utils.exception.CloudRuntimeException
Message: Unable to support this type of network broadcast domain: null
Stack: com.cloud.utils.exception.CloudRuntimeException: Unable to support this type of network broadcast domain: null
at com.cloud.hypervisor.xenserver.resource.CitrixResourceBase.getNetwork(CitrixResourceBase.java:2894)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixPrepareForMigrationCommandWrapper.execute(CitrixPrepareForMigrationCommandWrapper.java:60)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixPrepareForMigrationCommandWrapper.execute(CitrixPrepareForMigrationCommandWrapper.java:35)
at com.cloud.hypervisor.xenserver.resource.wrapper.xenbase.CitrixRequestWrapper.execute(CitrixRequestWrapper.java:122)
at com.cloud.hypervisor.xenserver.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:1779)
at com.cloud.agent.manager.DirectAgentAttache$Task.runInContext(DirectAgentAttache.java:306)
at org.apache.cloudstack.managed.context.ManagedContextRunnable$1.run(ManagedContextRunnable.java:49)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext$1.call(DefaultManagedContext.java:56)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext.callWithContext(DefaultManagedContext.java:103)
at org.apache.cloudstack.managed.context.impl.DefaultManagedContext.runWithContext(DefaultManagedContext.java:53)
at org.apache.cloudstack.managed.context.ManagedContextRunnable.run(ManagedContextRunnable.java:46)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:539)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
at java.base/java.lang.Thread.run(Thread.java:840)

versions

CloudStack 4.22.1.0+XCP-NG 8.2.1

The steps to reproduce the bug

  1. Create L2-network with some vlan-id;
  2. Connect a VM to L2-network;
  3. Statr the VM
  4. Migrate the VM to another pool's host

What to do about it?

No response

Activity

  1. DaanHoogland commented on Jul 27, 2026

    @DaanHoogland
    Contributor

    ah, this is the same as #13691. It may make more sense as a Q&A discussion item until we have root cause and can produce a fix. I am not sure if cross-pool migration is supposed to be supported.

  2. sptest232 commented on Jul 27, 2026

    @sptest232
    Author

    the error occurs when migrating VMs within the same pool

  3. locked and limited conversation to collaborators on Jul 28, 2026
  4. converted this issue into a discussion #13728 on Jul 28, 2026
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions