Skip to content

[BUG] vscode-server does not start if IPv6 is not available #218

Description

@Programie

Is there an existing issue for this?

  • I have searched the existing issues

Current Behavior

The container fails to start on a host where IPv6 has been disabled.

Expected Behavior

The container should start.

Steps To Reproduce

  1. Disable IPv6 on the Docker host
  2. Start the container with the latest code-server image
  3. The container fails to start due to being unable to bind to ":::8443"

Environment

- OS: Debian 11
- How docker service was installed: Official Debian package

CPU architecture

x86-64

Docker creation

services:
  code-server:
    image: linuxserver/code-server:4.127.0
    container_name: code-server
    hostname: code-server
    restart: unless-stopped
    volumes:
      - code-server:/config
      - code-server-data:/data
    environment:
      TZ: Europe/Berlin
      HASHED_PASSWORD: '<redacted>'
      DEFAULT_WORKSPACE: /data
    labels:
      traefik.enable: true
      traefik.http.routers.code-server.rule: "Host(`code-server.example.com`)"

Container logs

[2026-07-04T15:39:49.962Z] info  code-server 4.127.0 1e6ed874e3138141a5636f6e0dbe8570aa6cd001
[2026-07-04T15:39:49.963Z] info  Using user-data-dir /config/data
[2026-07-04T15:39:49.977Z] error listen EAFNOSUPPORT: address family not supported :::8443

Activity

  1. github-actions commented on Jul 4, 2026

    @github-actions

    Thanks for opening your first issue here! Be sure to follow the relevant issue templates, or risk having this issue marked as invalid.

  2. MnM001 commented on Jul 5, 2026

    @MnM001

    Same issue here

  3. pinguinfuss commented on Jul 6, 2026

    @pinguinfuss

    I guess the merge from commit 84a119f is causing this.

  4. madpeteguy commented on Jul 15, 2026

    @madpeteguy

    At least give us env var for listening addr config. For now it wont start without ipv6 support, its broken.

  5. MnM001 commented on Aug 12, 2026

    @MnM001

    Any fix for this issue? It has been a while....

  6. Programie commented on Aug 12, 2026

    @Programie
    Author

    There is a pull request to fix that (#219) but it hasn't been merged yet.

  7. LinuxServer-CI commented on Sep 11, 2026

    @LinuxServer-CI
    Collaborator

    This issue has been automatically marked as stale because it has not had recent activity. This might be due to missing feedback from OP. It will be closed if no further activity occurs. Thank you for your contributions.

  8. madpeteguy commented on Sep 11, 2026

    @madpeteguy

    Is this image abandoned? Will this issue get fix? Please "_"

  9. KeepBitcoinFree-org commented on Sep 20, 2026

    @KeepBitcoinFree-org

    Fear no more for I have found an easy workaround to bring back VSCODE-SERVER from the dead without IPV6. If you have any trouble with it, let me know.

    Run LinuxServer code-server Without IPv6

    1. Create the Dockerfile

    cat > Dockerfile <<'EOF'
    FROM lscr.io/linuxserver/code-server:latest
    
    RUN sed -i 's#\[::\]:8443#0.0.0.0:8443#g' \
        /etc/s6-overlay/s6-rc.d/svc-code-server/run
    EOF

    2. Build the derived image

    docker build --no-cache --pull -t code-server-no-ipv6:latest .

    3. Edit your Docker Compose file to use new image

        image: code-server-no-ipv6:latest #lscr.io/linuxserver/code-server:latest

    *A successful startup should include:

    Connection to 127.0.0.1 8443 port [tcp/*] succeeded!
    
  10. moved this from Issues to Done in Issue & PR Trackeron Sep 22, 2026
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions