Skip to content

[BUG] <Server unreachable / container OK> #439

Description

@cezarcretzu

Is there an existing issue for this?

  • I have searched the existing issues

Current Behavior

Mainly overnight but not only and more often in the past month the library becomes unavailable from any client. Docker logs show nothing out of the ordinary and the container shows up and running. The only option is to stop and restart the project. I chatgpted the issue but to no end.

Dug into some PMS logs and there were some transcoding errors (Error creating directory "/transcode": Permission denied) and chatgpt recommended to map a separate transcode folder, although all permitions were ok. Did that and keep testing.

Any help would be appreciated.

Expected Behavior

No response

Steps To Reproduce

n/a

Environment

DSM 7.3 Synology - up to date
DSM Container Manager install via project, docker compose - up to date

CPU architecture

x86-64

Docker creation

version: "3.9"
services:
  plex:
    image: linuxserver/plex:latest
    container_name: plex
    network_mode: host

Container logs

no errors in docker logs

this is from PMS download:

Error creating directory "/transcode": Permission denied

Activity

  1. github-actions commented on Jan 8, 2026

    @github-actions

    Thanks for opening your first issue here! Be sure to follow the relevant issue templates, or risk having this issue marked as invalid.

  2. kelbyc97 commented on Jan 9, 2026

    @kelbyc97

    I’m seeing the same thing - Plex doesn’t seem to have external network access though it’s been provided

  3. cezarcretzu commented on Jan 9, 2026

    @cezarcretzu
    Author

    i've disabled all ipv6 things as this was one of the things pointed by my dear friend chatgpt but it still showed it has access. last thing i've changed was in web PMS settings, network, selected ipv4 only. no hangs up to now but i need to still observe it

  4. Bjarne-Kinkel commented on Jan 9, 2026

    @Bjarne-Kinkel

    Same problem here, but switching to IPv4 only didn't do it for me. Any other ideas?

  5. cezarcretzu commented on Jan 12, 2026

    @cezarcretzu
    Author

    and again tonight. as always, no error in logs in container manager and a restart fixed it/

    one thing yesterday evening is that it seemed stuck on scaning the music library when some new files were added. other than that no other inputs.

    looking into plex logs i see lots of these messages during the night

    INFO - It's been 86673 seconds, so we're starting scheduled library update for section 6
    WARN - [Req#14b0ba] QueryParser: Invalid field 'contentDirectoryID' found, ignoring.
    WARN - [Req#14b0ba] QueryParser: Invalid field 'pinnedContentDirectoryID' found, ignoring.
    ERROR - [MetadataAgentManager/getAgent] Unable to find metadata agent provider for identifier 'com.plexapp.agents.none'
    WARN - [Req#14b58f] Held transaction for too long (/home/runner/_work/plex-media-server/plex-media-server/Library/MetadataCollection.cpp:1129)
    ERROR - [Req#14b101/MetadataAgentManager/getAgent] Unable to find metadata agent provider for identifier 'com.plexapp.agents.none'
    
  6. Sn0wCrack commented on Jan 15, 2026

    @Sn0wCrack

    Unsure it's related but I've noticed that Plex recently has started to randomly hang and freeze.
    Generally happens 20 minutes or so into playback. But it does seem to just happen as the container is running which continues to report it's okay.

  7. cezarcretzu commented on Jan 25, 2026

    @cezarcretzu
    Author

    aaaaand again this night. honestly can't pin point it. it makes no sense. no change happened. nothing. it's irritating.

  8. Sn0wCrack commented on Jan 25, 2026

    @Sn0wCrack

    Unsure it's related but I've noticed that Plex recently has started to randomly hang and freeze. Generally happens 20 minutes or so into playback. But it does seem to just happen as the container is running which continues to report it's okay.

    Update on this one. I changed to the Plex Pass beta branch and this started to work again. I have to assume this is some kind of upstream bug. It appears that Plex isn't planning on a new mainline release for a while due to the latest Beta using a new ffmpeg version.

  9. etriebe commented on Feb 7, 2026

    @etriebe

    This is happening to me, even on the latest beta for plex. The docker container will be consuming waaaay more CPU than it normally does even if nothing is being streamed with multiple lines saying it was seemingly restarting PMS.

    No update required
    [custom-init] No custom files found, skipping...
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    [ls.io-init] done.
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    Starting Plex Media Server. . . (you can ignore the libusb_init error)
    Critical: libusb_init failed
    
    
  10. j0nnymoe commented on Feb 7, 2026

    @j0nnymoe
    Member

    check the actual plex logs within your /config mount - it'll should show why it's restarting/crashing.

  11. xavierxc14 commented on Feb 8, 2026

    @xavierxc14

    I had the same problem and I find out it was a problem with old TLS certificates from the server and clients. I fixed by removing cached TLS certificates both from the server and the clients (remove applications and clean cache). I used this link as reference: https://forums.plex.tv/t/warn-cert-tls-connection/915433/4

  12. cezarcretzu commented on Feb 9, 2026

    @cezarcretzu
    Author

    had another freeze this morning. bellow plex last log before restart. not sure how to read it. chatgpt says a lot but sometimes is difficult to trust it considering many times has answers like: "indeed you are right, humans cannot flap their hands and fly; let me rephrase it"

    Feb 09, 2026 06:02:28.658 [139761930341176] WARN - [Req#2c5c5a/Database optimization/com.plexapp.plugins.library.db/DatabaseFixups/41DatabaseFixupsDeleteUnusedTagsAndTaggings] Held transaction for too long (/home/runner/_work/plex-media-server/plex-media-server/Library/DatabaseFixups.cpp:239): 0.580000 seconds Feb 09, 2026 06:02:28.761 [139761930341176] WARN - [Req#2c5c5a/Database optimization/com.plexapp.plugins.library.db/DatabaseFixups/35DatabaseFixupsConsolidatePeopleTags] Held transaction for too long (/home/runner/_work/plex-media-server/plex-media-server/Library/DatabaseFixups.cpp:374): 0.170000 seconds Feb 09, 2026 06:34:58.890 [139761937595192] WARN - NAT: PMP, got an error: Not Supported by gateway. Feb 09, 2026 06:34:58.974 [139761937595192] WARN - MPM: ignoring preferred-interface pref due to no matching valid address

  13. cezarcretzu commented on Mar 2, 2026

    @cezarcretzu
    Author

    changed some of the jobs running on my nas. hyper backup from 0300AM to 07AM for example

    noticed this morning that at 0659-0700 plex became unreachable. noticed this via plexamp which could not access library. at 0651 kometa finished the nightly job as well.

    so i'm thinking maybe something between these two guys here could triger this? kometa works with plex so it would make some sense, hype back up don't see how.

    any inputs are more than welcomed

  14. cezarcretzu commented on Mar 2, 2026

    @cezarcretzu
    Author

    played a bit with chatgpt and the logs and it somehow narrowed it down to this

    Plex was transcoding, and it was specifically EAE (EasyAudioEncoder) for EAC3 failing for hours

    seems to be full of errors with this EAE

    did some modification specifically to /transcode and /tmp folders access

    will report back

  15. cezarcretzu commented on Mar 6, 2026

    @cezarcretzu
    Author

    after tinkering with the help of chatgpt got to narrow it down to one possible culprit: tautuli. it seem that it was overflowing plex with requests that were actually blocking traffic to server. docker was reporting up and running, but server was unreachable.

    stopped tautuli since 2 days now and fingers crossed but no issue (2 days is for sure not enough to draw a conclusion)

    will report back in few days time

    Most likely root cause (based on your evidence) Connection churn causing backlog overflow The high CLOSE_WAIT count + high ListenOverflows/ListenDrops strongly points to Plex not accepting/processing new TCP connections fast enough. CLOSE_WAIT means the peer closed, but the server-side socket wasn’t closed yet (application not cleaning up promptly). A local client hammering Plex 172.18.0.2 being the top source and mapping to Tautulli is consistent with “polling too aggressively” or stuck retry loops during a Plex issue. Stopping Tautulli did not immediately clear existing CLOSE_WAIT sockets (expected; they remain until Plex closes them), and Plex already appeared wedged.

  16. cezarcretzu commented on Mar 11, 2026

    @cezarcretzu
    Author

    a week in and no errors after stoping tautuli. maybe indeed this was the culprit. i like tautuli, but i like more the server running all the time. plex dash is good enough on mobile if needed.

    LE: two weeks in, zero errors with tautuli stopped. don't even want to try and start it again. can live without it.

  17. LinuxServer-CI commented on Apr 24, 2026

    @LinuxServer-CI
    Contributor

    This issue has been automatically marked as stale because it has not had recent activity. This might be due to missing feedback from OP. It will be closed if no further activity occurs. Thank you for your contributions.

  18. moved this from Issues to Done in Issue & PR Trackeron Jun 23, 2026
  19. LinuxServer-CI commented on Jul 24, 2026

    @LinuxServer-CI
    Contributor

    This issue is locked due to inactivity

  20. locked as resolved and limited conversation to collaborators on Jul 24, 2026
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Type

    No type

    Projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions