Repository navigation
[BUG] PLEX Roku client restarts PLEX server within container #450
Description
Activity
Thanks for opening your first issue here! Be sure to follow the relevant issue templates, or risk having this issue marked as invalid.
The libusb error isn't something to worry about.
You need to look at the actual Plex console logs (or tail the Plex log file in/config) to see what's happening.I'm a heavy roku user with Plex and do not have this issue.
Correct, the libusb is for it not finding a usb TV tuner, I use it as a flag for when the server is ready.
Yeah, I don't know why it's happening. I had PLEX on a Windows mini PC before this and PLEX ROKU worked just fine.
The Logs directly has "Plex Crash Uploader.log" files but when I go to the crash reports directory, the folders are empty.
In the "Plex Media Server #.log" there's nothing stating any sort of issue. It just creates a new log and a Plex Crash Uploader.log every time I open the ROKU PLEX app
I think you need to report this to plex, it might be a bug they've introduced.
Reacted by INDE TexHere's a video of it in action since I can't attach a MP4: https://photos.app.goo.gl/HSVpgrJnaQ7LMX3Z6
I think you need to report this to plex, it might be a bug they've introduced.
You're right. I rolled back 3 versions and everything works perfectly. I hadn't actually used PLEX yet as I was in the process of setting up my server. For some reason 1.43.1.10576-06378bdcd-ls300 crashes the internal PMS and restarts it when I load my ROKU PLEX app. Utterly bizzare. Thanks for your help. I'd consider this closed.
This issue has been automatically marked as stale because it has not had recent activity. This might be due to missing feedback from OP. It will be closed if no further activity occurs. Thank you for your contributions.
This issue is locked due to inactivity
- locked as resolved and limited conversation to collaborators
on Aug 8, 2026
Metadata
Metadata
Assignees
Type
Projects
- StatusShow more project fieldsDone
Is there an existing issue for this?
Current Behavior
I start the ROKU plex app and my PLEX server crashes.
Expected Behavior
ROKU app accesses PLEX normally.
Steps To Reproduce
Environment
CPU architecture
x86-64
Docker creation
plex: image: lscr.io/linuxserver/plex:latest container_name: plex #network_mode: host #I've noticed no difference between host & bridge; bridge used for short name in internal bridge network environment: - UMASK=000 - PUID=99 - PGID=100 - TZ=America/Chicago - VERSION=docker #- PLEX_CLAIM= #https://account.plex.tv/claim ports: - 32400:32400 - 1900:1900/udp - 5354:5353/udp #adjusted for unraid's mDNS - 8324:8324 - 32410:32410/udp - 32412:32412/udp - 32413:32413/udp - 32414:32414/udp - 32469:32469 devices: - /dev/dri:/dev/dri #for quicksync volumes: - ./PLEX/config:/config - /mnt/user/media:/media:ro #- /dev/shm:/transcode # /dev/shm defaults to half system RAM - /etc/localtime:/etc/localtime:ro restart: unless-stopped tmpfs: - /transcode:size=64G labels: - homepage.group=Public - homepage.icon=sh-plex - homepage.name=PLEX - homepage.description=Media server - homepage.href=http://nostromo.local:32400 networks: DLNetwork: aliases: - plexContainer logs
─────────────────────────────────────── ██╗ ███████╗██╗ ██████╗ ██║ ██╔════╝██║██╔═══██╗ ██║ ███████╗██║██║ ██║ ██║ ╚════██║██║██║ ██║ ███████╗███████║██║╚██████╔╝ ╚══════╝╚══════╝╚═╝ ╚═════╝ Brought to you by linuxserver.io ─────────────────────────────────────── To support LSIO projects visit: https://www.linuxserver.io/donate/ ─────────────────────────────────────── GID/UID ─────────────────────────────────────── User UID: 99 User GID: 100 ─────────────────────────────────────── Linuxserver.io version: 1.43.1.10576-06378bdcd-ls300 Build-date: 2026-04-08T15:47:20+00:00 ─────────────────────────────────────── **** permissions for /dev/dri/renderD128 are good **** **** permissions for /dev/dri/card0 are good **** Setting permissions on /transcode **** Server already claimed **** Docker is used for versioning skip update check [custom-init] No custom files found, skipping... Starting Plex Media Server. . . (you can ignore the libusb_init error) [ls.io-init] done. Critical: libusb_init failed Starting Plex Media Server. . . (you can ignore the libusb_init error) Connection to localhost (::1) 32400 port [tcp/*] succeeded! Critical: libusb_init failed Starting Plex Media Server. . . (you can ignore the libusb_init error) Connection to localhost (::1) 32400 port [tcp/*] succeeded! Critical: libusb_init failed Starting Plex Media Server. . . (you can ignore the libusb_init error) Connection to localhost (::1) 32400 port [tcp/*] succeeded! Critical: libusb_init failed