Repository navigation
chore(deps): upgrade all dependencies; next 16.4.3 (RCE GHSA-2464-fhr4-w9xw) - #299
Conversation
…4-w9xw) next 16.4.2 -> 16.4.3, eslint 10, @vitejs/plugin-react 6 (+ vite 8 as an explicit devDependency so the peer stops resolving vite 7), @profullstack stack 0.5 / x402-gateway 0.13 / player 0.16; epubjs xmldom 0.7 -> 0.8.15 via override. Held: typescript 6 (7 has no JS API). Co-Authored-By: Claude Opus 5.5 <[email protected]>
|
Review the following changes in direct dependencies. Learn more about Socket for GitHub.
|
|
Warning Review the following alerts detected in dependencies. According to your organization's Security Policy, it is recommended to resolve "Warn" alerts. Learn more about Socket for GitHub.
|
ThreatCrush Security Scan97 finding(s) HIGH/CRITICAL: 11 | MEDIUM: 30 | LOW: 56
…and 47 more. Full results in the Security tab. Snippets are redacted; ThreatCrush never prints matched credential material. |
Fleet dependency upgrade (2026-10-26). Driver: Next.js unauthenticated RCE advisories GHSA-2464-fhr4-w9xw / GHSA-673q-mjm6-r5xr.
Security
next16.4.2 -> 16.4.3 (+ eslint-config-next)pnpm audit --prod: critical 0 -> 0, high 15 -> 1, moderate 6 -> 0. The one left isip(<=2.0.1, no patched release) under webtorrent > bittorrent-tracker.epubjs>@xmldom/xmldom: ^0.8.15(epubjs pins the vulnerable 0.7 line).Majors taken
eslint 10, @vitejs/plugin-react 6 (vite 8 added as an explicit devDependency: without it the plugin's peer resolved vite 7 and vitest could not load its config). Everything else to latest in range: @profullstack/stack 0.5, x402-gateway 0.13, player 0.16, openai, puppeteer, pg 8.23, imapflow, mailparser, posthog-js.
Held
typescript 6.0.3 (7.x is the native compiler with no JS API for typescript-eslint / next build).
Gate
typecheck clean; lint 0 errors; vitest 240 files / 3108 tests pass;
next buildsucceeds.🤖 Generated with Claude Code