You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
This PR bumps utopia-php/queue from ^0.19 to ^0.20 (resolving to 0.20.0), which drops the php-amqplib/php-amqplib transitive dependency (RabbitMQ support removed upstream) and pulls in utopia-php/pools 1.0.4 as a side-effect.
utopia-php/queue 0.20.0 raises its PHP floor to >=8.4, but the platform's own composer.json still declares php: ">=8.3" — this mismatch means Composer will fail on PHP 8.3 hosts.
Three transitive packages (php-amqplib/php-amqplib, phpseclib/phpseclib, paragonie/*) are cleanly removed from the lock file; no source files in this repo reference them directly.
Confidence Score: 3/5
Not safe to merge without updating the declared PHP minimum: the package claims 8.3 compatibility but will fail to install on 8.3 hosts.
The only required code change — bumping the php constraint in composer.json from >=8.3 to >=8.4 — is missing. Without it, any consumer or CI environment on PHP 8.3 will get a Composer resolution failure, and the library's advertised compatibility is incorrect.
composer.json — the php platform requirement needs to be raised to >=8.4 to match the new transitive floor imposed by queue 0.20.0.
Important Files Changed
Filename
Overview
composer.json
Queue constraint bumped from ^0.19 to ^0.20, but the declared php minimum (>=8.3) is now lower than what queue 0.20.0 requires (>=8.4).
composer.lock
Lock file regenerated for queue 0.20.0; php-amqplib and phpseclib transitive deps removed (no longer needed), utopia-php/pools bumped to 1.0.4.
The project declares php: ">=8.3", but utopia-php/queue 0.20.0 (now pinned via composer.lock) requires php: ">=8.4". This means Composer will fail to resolve dependencies on any PHP 8.3 host, making the declared minimum version incorrect. The php constraint in composer.json should be tightened to match the strictest transitive requirement.
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Bumps
utopia-php/queuefrom^0.19to^0.20(0.20.0 installed).Changes
composer.json:utopia-php/queueconstraint^0.19→^0.20composer.lock: regeneratedVerification
composer updateresolves cleanly to queue 0.20.0composer lint)Platform.php(Adapter\Swoole,Server) remain present in 0.20🤖 Generated with Claude Code